2
$\begingroup$

I installed Coq from the 8.15 64-bit installation file in Windows. I ran coqide and got the error message:

GdkPixbuf-WARNING **: Cannot open pixbuf loader module file

It says to run gdk-pixbuf-query-loaders for a temporary fix but there is no such program on my system. Do I have to download and install another program?

If this is just a temporary fix, is there is permanent one?

Added: I am new to Coq so I can't really tell what is working and what is not. CoqIDE did appear and I managed to run a program with Check 0. and Check nat., but then it crashed. For now I'll work through the tutorials from the command line and hope that eventually someone can help us unfortunately people who use Windows....

$\endgroup$
4
  • $\begingroup$ Does coqide still run? If that's the case it's safe to ignore the warning $\endgroup$
    – Couchy
    Nov 20 at 16:47
  • $\begingroup$ I can reproduce and the IDE runs. It's just the terminal window is very annoying $\endgroup$
    – ice1000
    Nov 20 at 20:06
  • $\begingroup$ @ice1000 I don't get the warnings, do you need to do anything particular? Do the icons display properly? $\endgroup$
    – Couchy
    Nov 21 at 6:28
  • $\begingroup$ @Couchy everything is fine except that CoqIDE always comes with a terminal window with warnings $\endgroup$
    – ice1000
    Nov 21 at 10:35

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.